5.7 hemi jetting nightmare

Discussion of the 5.7L-6.1L-6.4L HEMIs.

Moderator: scottm

Post Reply
bigdanv8
Posts: 2
Joined: Sat May 23, 2009 4:55 pm
Location: ste agathe des monts quebec canada

5.7 hemi jetting nightmare

Post by bigdanv8 » Wed Jul 08, 2009 3:53 pm

Hi Everyone!

I`m new here but it seems like there is wealth of knowledge here so I thought I would see advice if any I could get on this there it goes.

2004 5.7 Hemi 16000 miles swapped into a 1980 jeep cj7
transmission 727
650 Holley
xv motorsport intake
msd Hemi 6 controller

jeep has no power is run to rich the primaries is well but went the secondaries go on it has a
tipycal sound to is run to rich.

I work on that 2 monthI change jetting 74 at 72 70 67 I have no power.
I change the power valve the 7.5 at 6.5 I have no power.
I check my ground and the b+
I change the carb for a 3310 same problem.
I check the vacum is around 20 hg.
I dont no if the problem is on the carb!
jojohemi had a same thing I writh on the forum but I dont no if settle that!
Sorry for my english I m french.I work hard with my dictionary.
:) :)

392heminut
Posts: 488
Joined: Sat Nov 30, 2002 2:16 pm

Re: 5.7 hemi jetting nightmare

Post by 392heminut » Tue Jul 14, 2009 8:50 am

Have you checked the plugs to see if it is actually running rich? The power issue could be timing, the MSD controller only has 25 degrees of total timing in the stock map.
Owner of the Poor Man's Hemi Cuda

bigdanv8
Posts: 2
Joined: Sat May 23, 2009 4:55 pm
Location: ste agathe des monts quebec canada

Re: 5.7 hemi jetting nightmare

Post by bigdanv8 » Tue Jul 14, 2009 4:15 pm

yes the plug is black and I upgrade my timing at 30 .
I dont no is good.

Post Reply